This is an archived forum post. The information may be outdated. Contact us if you have any questions.

Timed Out. Can't load the specified URL.

masonkessinger wrote on 2012-06-07:

My client has contacted me to let me know that their URL to PDF service is no longer working. It appears to be timing out.

Here is the URL:|%20Page%20%p%20of%20%n%20&width=8.5in&height=11in&vmargin=.5in&hmargin=.75in&use_print_media=1&pdf_name=Renee%20Atlas%20Biography

Here is the server response:

Timed out. Can't load the specified URL.

List of the resources that can't be loaded:

Is there some way you could help me to figure out what is happening here? This was working last week and now its not. Is this a server issue?
support wrote on 2012-06-07:

our service times out while loading

This seems to be related to yesterday's World IPv6 launch:
$ curl -v ''
* About to connect() to port 443 (#0)
*   Trying 2001:4998:f00b:1fe::3000... Timeout
*   Trying 2001:4998:f00b:1fe::3001... Timeout

I'm not sure if the website is misconfigured or if it is an IPv6 SSL issue on our end. I will investigate this further and post an update here.

To get the PDF link working your client should disable the link temporarily or use the http version ( which seems to work correctly.
support wrote on 2012-06-07:
Can you try it now?
louis wrote on 2012-06-08:
I'm also having the same error with the following url:

Can you tell me when this will be resolved?
support wrote on 2012-06-08:
@louis: returns 404 (Not Found) now. Is the URL correct?
masonkessinger wrote on 2012-06-08:
It appears that this issue is resolved for me. Thanks guys.
louis wrote on 2012-06-08:
Sorry. Try this one
louis wrote on 2012-06-08:
Also, using the static ip address doesn't seem to work either

These urls work in your converter at homepage, but I just get a timeout error in the API now.
support wrote on 2012-06-10:
I tried the url on the homepage and in the API and it worked as expected in both cases. Please can you post your API integration code?
louis wrote on 2012-06-11:
It seems to be working now. I no longer get the Timed Out error. Thanks
louis wrote on 2012-06-13:
Actually my previous post is false. It works when using the ip address, but using the URL gives me a time out error:

Pdfcrowd::Error (510 - Timed out. Can't load the specified URL.

List of the resources that can't be loaded:

The ruby on rails code that calls this is:
pdf = client.convertURI(calendarPrint_home_path(, :only_path => false))

Would be very good to have this working, as my clients need this functionality.
support wrote on 2012-06-14:
I tried the URL and it works now.

One possible reason why you are (sometimes) getting this error could be a connect timeout while our service attempts to establish a connection to When you get the pdfcrowd timeout error, are you able to verify in your logs that your app received a GET request from our service and completed it successfully?

Another reason could be some DNS issue. How old is the DNS A record for, did you change it recently?

Btw, I'm not sure if this is related to this issue but both ping and mtr fail:
$ mtr -r -c 20
HOST: crowd                       Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.                   0.0%    20    1.5   6.9   0.5  24.2   7.5
  2.                  0.0%    20    0.4   0.8   0.4   5.2   1.0
  3.      0.0%    20    0.4   0.5   0.3   1.6   0.3
  4.       0.0%    20    1.5   1.6   1.4   3.0   0.4
  5.        0.0%    20    1.5   3.6   1.4  13.0   3.7
  6.  0.0%    20    1.7   1.5   1.4   1.8   0.1
  7. rc1we-tge0-0-0-0.ed.shawcabl  0.0%    20   13.8  13.9  13.8  14.1   0.1
  8. rc2sc-pos0-7-4-0.wp.shawcabl  0.0%    20   42.7  41.3  39.0  43.5   1.4
  9.     0.0%    20   50.8  50.9  50.7  51.2   0.1
 10. ???                          100.0    20    0.0   0.0   0.0   0.0   0.0

$ping -v -w 5 -p 5
PING ( 56(84) bytes of data.

--- ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 4999ms
louis wrote on 2012-06-18:
I finally got this working by deleting the subdomain and recreating it. Not sure why I had to do that, but it worked in this case.
louis wrote on 2012-06-20:
I'm dissappointed to say that this problem is happening yet again. all subdomains ending in and even the ip address does not work using the API. Same error message as before. It does seem to be intermittant, because I had success 2 days ago, and now I'm back to failure. I know my website is up and the URL seems accessible from anywhere else but your API. Here is another example url for reference:
support wrote on 2012-06-21:
1/ Do you see any activity from us ( in your server/firewall logs at the time the error occurs?

2/ It seems that ICMP is disabled on your server (both mtr and ping fail, see the previous post). Is it possible to enable it? We would like to eliminate any possible influence as disabled ICMP may cause e.g. black hole connections. More about implications of disabled ICMP is e.g. here:

3/ Since the issue is intermittent we can setup a check (via that would periodically check the URL every minute from multiple locations for a few days. This way we could find out if the issue is really specific to our API. Do you agree?
louis wrote on 2012-06-21:
1. I do see logs from when it is successfull. I don't think there are any when it fails. I'm checking my application log, but I haven't checked the apache logs yet.

2. I think I have successfully enabled ICMP, let me know if thats not the case

3. Thanks for the heads up on It looks like a great service. I've set up a free account to monitor (my primary client) It seems the free account only lets you do http monitoring, and not pinging or any other type of test. Hopefully that is sufficient
louis wrote on 2012-06-21:
UPDATE: I checked the Apache access logs, and I am in fact getting a request from when it fails. I'm watching it in real time, using tail -f and it seems that it take a long time (20 seconds or so) after I make the request to create a pdf that it shows up. Whereas when it succeeds I get the log entry right away.

I get the following Ruby on Rails application error :

Started GET "/homes/32/pdf_calendar" for at Thu Jun 21 10:41:03 -0500 2012
Processing by HomesController#pdf_calendar as HTML
Parameters: {"id"=>"32"}
Completed 500 Internal Server Error in 42770ms

Pdfcrowd::Error (510 - Timed out. Can't load the specified URL.

List of the resources that can't be loaded:
app/controllers/homes_controller.rb:79:in `pdf_calendar'

Started GET "/homes/32/calendarPrint" for at Thu Jun 21 10:41:46 -0500 2012
Processing by HomesController#calendarPrint as HTML
Parameters: {"id"=>"32"}
Rendered homes/calendarPrint.html.erb within layouts/application (3.7ms)
Completed 200 OK in 6ms (Views: 4.2ms | ActiveRecord: 0.5ms) (510 - Timed out. Can't load the specified URL.

and the following Apache access log: - - [21/Jun/2012:10:41:06 -0500] "GET /homes/32/calendarPrint HTTP/1.1" 200 3763 "-" "Mozilla/5.0 (X11; U; Linux; en-US) AppleWebKit/531.2 (KHTML, like Gecko) Safari/531.2"
louis wrote on 2012-06-21:
Further UPDATE: I'm not sure why its happening, but it seems to have something to do with multiple subdomains or virtual hosts on the server. When I restart apache service, It will work for the first subdomain I try it on, but only that subdomain, no others.

Here are the steps I take to reproduce it:
1. restart apache service.
2. attempt api conversion of SUCCESS
3. attempt api conversion of FAIL
4. restart apache again
5. attempt api conversion of SUCCESS
6. attempt api conversion of FAIL

So the first subdomain I attempt a conversion on seems to work from then on, while the other subdomain fails. On subsequent conversions it keeps succeeding on the first subdomain and failing on the second one. The whole time, all of these URLS are accessible from the internet and the site is never down. Any ideas? Does this seem like an error within the Ruby on Rails PDFCrowd API?
support wrote on 2012-06-22:
1/ Please post source code of involved RoR controllers.

2/ Do you have any explanation why the timestamps in the logs differ by 40 seconds?
-- apache: - - [21/Jun/2012:10:41:06 -0500] "GET /homes/32/calendarPrint HTTP/1.1" 200 3763 "-" 
-- ruby:
Started GET "/homes/32/calendarPrint" for at Thu Jun 21 10:41:46 -0500 2012 

3/ Are you getting the error when the API is called via curl? (replace <username> and <apikey> with your credentials)
curl -o out.pdf -v -F username=<username> -F key=<apikey> -F src=

4/ Can you run tcpdump on the server at the time the error occurs and send us the output file (tcpdump.raw) to
$ sudo tcpdump -ni any -w tcpdump.raw
# trigger the timeout error, i.e. send a GET to /homes/32/pdf_calendar that fails
$ [Ctrl+C]