This is an archived forum post. The information may be outdated. Contact us if you have any questions.

Turn off automatic scaling of PDFs with huge embedded images

mvirtue wrote on 2014-10-29:
When our application generates a PDF from HTML using the API, and that HTML contains a VERY large image, the scale/zoom/something of the resulting PDF is altered so that the image completely fits on the page. This is helpful, of course, but the OTHER html content then becomes so small as to be unreadable.

See attached image (this is a screenshot of the PDF, as the actual PDF was > 200Kb and so couldn't be uploaded to this post)...

Is there any way to turn off this automatic scaling/zooming? In the API, I've tried changing the values of "pdf_scaling_factor" and/or "html_zoom", but it makes no difference.

Any thoughts would be much appreciated.

support wrote on 2014-10-29:
Hello Mark,

No there is no such a setting in the API.
One option you could consider is to change the PDF page size (via the width and height parameters) so that it matches the HTML document size.
mvirtue wrote on 2014-10-29:
Thanks Support.

That option wouldn't work, as we don't know what the HTML document size is.

Thanks anyway.