This is an archived forum post. The information may be outdated. Contact us if you have any questions.

Can't edit PDF after generation

sfscrabble wrote on 2014-03-31:
First let me say I am very impressed with the accuracy of a fairly complex design I have been able to achieve using your service, thank you.

However, after generating a PDF I get an error every time if I try to use the content editing -> edit text & images tools and get an error most of the time if I try to replace/delete pages in the document (using Acrobat XI Pro). There properly is no security set and all editing, etc. shows up as "allowed" in the document profile.

Any idea why these PDFs would not allow these basic editing features after generation?
support wrote on 2014-04-02:

Could you try to re-save the file in Acrobat and then edit it?
sfscrabble wrote on 2014-04-02:
Thank you for responding.

I have tried resaving them and it doesn't change. So I just tried to Save As Other -> Reduced Size PDF and Save As Other -> Optimized PDF. These generate "An Error was encountered while optimizing content streams " Which I believe points to a font or image problem. This then lead me to notice that the pdf reports no embedded fonts in the optimize dialog, but does list some subset fonts in properties.

Is there a way to set the service to embed the complete font instead of subsets?

I will also look into generating these without custom fonts and/or SVG images to narrow the problem and post the results here.

Thanks again for the great service!
support wrote on 2014-04-02:
Thanks for the info. Well, there may be a variety of reasons why is Acrobat unable to edit the file and it is really hard to determine which one it is.

Regarding the fonts, it is not possible to set the service to embed the complete fonts. It always embeds subsets.